Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"Directory is corrupted and unreadable"


  • Please log in to reply
2 replies to this topic

#1 framerw47

framerw47

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:54 PM

Posted 31 January 2005 - 11:10 PM

Hi all, I just joined the forum. Unfortunately, I need some help badly right now, but I can return later and offer some help. I have learned a few things over the years.

I'm having problems with "Directory corrupted and unreadable" in XP Pro.

I did a search for info on the forum and the only topic that came close to my problem appears to have been closed.

Here's my deal.

I have a folder in "My Documents" called "My eBooks". When I try to open this folder I get the aforementioned response. This is the only folder I have found that gives this error message. It was working fine Sat. night when I went to bed. When I got up Sunday morning and tried to open the folder, it wouldn't open.

The only thing I have done out of the ordinary is install "Adobe Acrobat 7 trial version"-downloaded directly from Adobe.com. I didn't go near "My eBooks" when I downloaded or installed it. I downloaded it to my desktop and installed it from there.

My current configuration has been working pretty good until Sunday morning, although I could stand a clean install.

Homebuilt computer, Athlon Duron 1300+; 2 WD 7200 RPM 80 gig hard drives;Dual boot-98SE on C:\... XP Pro on D:\ ; AVG antivirus Home Edition; Zone Alarm free edition.

System restore wouldn't bring it back.

Chkdsk will run but won't fix the problem. Chkdsk /F will not run. It says "the volume is in use by another process". I have tried scheduling it to run at next startup, but it still won't run. At that time it gives a message something about "appearing to be a non-windows disk".

I am considering running the Data Lifeguard Tools 11 diagnostic from Western Digital, but want to wait till I hear from the forum.

Anybody have an idea how to fix it or at least get into the folder so I can get my books on CD? If I could just get my books, I would do a format and clean install and be happy. If any more information is needed I'll be happy to oblige.

Anybody have any first hand experience with the software "Active-UnDelete" ? If so, will it help me?

Thanks in advance for any help!

Edited by framerw47, 31 January 2005 - 11:13 PM.


BC AdBot (Login to Remove)

 


#2 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,622 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:09:54 PM

Posted 01 February 2005 - 08:41 PM

Have you tried running Chkdsk /F in safe mode?

Is this an ntfs filesystem?

If it is ntfs click on start then run and type cmd and press enter.

Then type the following and press enter:

chkntfs /C c:

Some of these other steps may help:

http://www.pcbuyerbeware.co.uk/RecoveringXP.htm#chkdsk

#3 gud4u

gud4u

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 02 February 2005 - 10:19 AM

CHKDSK (use help for appropriate parameters) is excellent and can be run from the recovery console. It test both file system and HD bad-block integrity.

I would follow that by running WD DLGDIAG. DLGDIAG has found weak read/write blocks on my WD HD that CHKDSK didn't detect. I attribute this to better control of HD head read-sensitivity with DLGDIAG.

Hope this helps!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users