Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Intel Pro 2200bg On Xp Pro Won't Renew Dhcp Lease


  • Please log in to reply
5 replies to this topic

#1 twardnw

twardnw

  • Members
  • 259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR
  • Local time:07:45 AM

Posted 09 August 2007 - 03:33 PM

Ok, Toshiba Satellite, unsure of model. XP Pro, all nicely updated. Intel Pro 2200 BG internal wifi card. Using the Intel Wireless manager.

Hadn't been able to get a good address when attempting to release/renew on the card. Tried everything I could think of, updated the drivers, removed encryption from the access point, tried connecting to a different network. Nothing would make it get a new (proper) address. Except for one thing, when the driver was reinstalled, it would properly get an address via DHCP and work nicely. Reboot, then nothing, won't get a proper address no matter what.

Swapped in the wifi card from my laptop, Intel 2915 ABG, it's based on the same driver. Detected the card on boot-up, Winblows installed the driver, connected very happily to the network. Reboot. Now it won't get an address.

This made me think. So, I went into the device manager, deleted the card, re-detected it, it joined the network no problem, and received a proper address via DHCP.

Any thought on this one?

Oh yeah, I also did a repair install of XP thinking maybe there was some Winblows update the broke things. No such luck.

BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:10:45 AM

Posted 10 August 2007 - 05:47 AM

Have you tried connecting to the network manually when it doesn't give you an address?
Have you tried to recycle the router (remove the power cord from the router and turn the PC off, wait 3 minutes, turn the router back on, wait 3 minutes, turn the PC back on)?
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#3 twardnw

twardnw
  • Topic Starter

  • Members
  • 259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR
  • Local time:07:45 AM

Posted 10 August 2007 - 09:19 PM

yes to both. Setting a static address works, but this computer is used on several networks, so that is not a permanent solution. As for resetting the router, I have done that, but this is the only computer with these symptoms. My Pocket PC phone, my Fedora Core laptop, and another Windoze laptop used at that site are all able to correctly retrieve addresses via DHCP.

Edited by twardnw, 10 August 2007 - 09:19 PM.


#4 pascor22234

pascor22234

  • Members
  • 403 posts
  • OFFLINE
  •  
  • Local time:10:45 AM

Posted 10 August 2007 - 09:32 PM

If the above sequence doesn't work you can go one step further. First use Device manager to Uninstall the wireless adapter.
Control Panel > System > Hardware tab > Device Manager button
Click the plus sign to the left of Network adapters to expand the list. Find the wireless adapter. Right-click on the entry and select Uninstall.

Shut down the PC but don't restart yet. Turn off the power from the router. If you have a high speed modem turn off its power. Wait 20 seconds. Power the modem back on. Wait until all its status lights have settled to a steady state. Power back up the router. Wait another 20 seconds. Restart your PC. XP will reinstall the wireless drivers. You'll probably be able to connect.

Restart your PC and see if you are able to connect now. Apparently, in some cases letting XP reinstall the drivers makes some settings that are not able to be made any other way. This is a flaw in XP, of course. I learned this trick the hard way from a phone technician from a cable ISP company. I hope it works for you.

#5 twardnw

twardnw
  • Topic Starter

  • Members
  • 259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR
  • Local time:07:45 AM

Posted 11 August 2007 - 05:41 PM

That's pretty much what I've been doing, but I gave it a try again, no such luck. this time though it didn't make it as far even. Wouldn't pick up an address even immediately after the drivers installed.

#6 twardnw

twardnw
  • Topic Starter

  • Members
  • 259 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portland, OR
  • Local time:07:45 AM

Posted 11 August 2007 - 06:23 PM

well, I'm not sure what I did. But now it works. The driver version is the same as it has been, windows installed it automatically. Oh well, who knows. Hope it keeps working strong.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users