Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Svchost.exe


  • Please log in to reply
8 replies to this topic

#1 techfeel

techfeel

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:59 PM

Posted 26 July 2007 - 04:55 AM

Hi i have problem each time i log in.When i log in,it shows unable to find SVCHOST.exe.Please check the path of the file.

Previously,i ended the svchost.exe process suspecting it for virus.From then on am having this problem.In Start menu i have lost some utilities like paint,calculator.

Is there any solution for this? :thumbsup:

BC AdBot (Login to Remove)

 


#2 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 PM

Posted 26 July 2007 - 05:00 AM

Please double-check if it was SVCHOST.EXE or SCVHOST.EXE (note the slightly different spelling). The first is a normal Windows component and the second is a Trojan.

If you're sure it was the first try running the System File Checker.

How to Use SFC.EXE to Repair System Files
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#3 techfeel

techfeel
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:59 PM

Posted 26 July 2007 - 05:06 AM

ITs the first one.thanks for the solution. I'l post after running SFC.EXE

Edited by techfeel, 26 July 2007 - 05:07 AM.


#4 techfeel

techfeel
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:59 PM

Posted 27 July 2007 - 05:11 AM

Hi now only i found that i wrongly misspell to you the file name.

The file name is "SCVHOST.EXE" & not "SVCHOST.EXE" as you said.I ran scanning through anti virus program.IT detected several virus in the file b133.exe.It couldn't clean or move the file.so I tried to remove manually & was not able to do.Same way i have two more files containing virus.But not able to remove it.But the last two are separate application files downloaded from internet.

Am confused what to do now?

#5 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 PM

Posted 27 July 2007 - 05:27 AM

What you can try is to install several anti-spyware programs (if you haven't already) such as:

AVG Antispyware
SuperAntiSpyware
Spybot

These are all free.

Install these and update them so you have the latest definitions, and also update your anti-virus.

Then re-boot into Safe Mode and scan with each one. If that doesn't solve your problem post back and we'll take it from there.


Edit: fixed a typo

Edited by Budapest, 27 July 2007 - 05:27 AM.

The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#6 techfeel

techfeel
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:59 PM

Posted 27 July 2007 - 06:58 AM

thanks a lot.I'll try with the things you said & will get back to you

#7 techfeel

techfeel
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:59 PM

Posted 29 July 2007 - 11:40 PM

Hi budhapest.Thanks a Lot for providing me valuable solution.As you said I used the above said tools and scanned my system.
I FOUND the virus which displays scvhost.exe message on boot up & eliminated it.I also found several other virus and suppressed it.

Now i have a problem with the virus in b133.exe file.Four instances of it has been affected by spywares & virus.

This wasn't detected in the above said tools.I found it through Bitdefender internet security v10.But bitdefender isn't cleaning up that file.It just points out the virus & well also protects me when it tries to attack.

How to eliminate it.I tried manual deletion but i got error message as "Can't read from source"

Thanks Once again to help me in getting rid of th viruses present before.

#8 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 PM

Posted 30 July 2007 - 12:52 AM

I would suggest that you post a HijackThis log and let the experts sort it out.

Preparation Guide for use before posting a HijackThis Log
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#9 techfeel

techfeel
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:59 PM

Posted 30 July 2007 - 02:43 AM

Thanks .I'll post a Hijackthislog




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users