Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Home Network Setup Help


  • Please log in to reply
12 replies to this topic

#1 funnytim

funnytim

  • Members
  • 624 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:31 AM

Posted 23 July 2007 - 08:07 PM

hi guys, i'm having a problem w/ home networking.

i have 2 computers which i'd like to network them, so both comps can c each other's files & printers.

Both computers can access the internet OK, and both run XP Pro

I've run the Network Setup Wizard on both comps, so they're both configured to be able to share files & printers. however, i can't get them to "see" the other comp's files!! WHen i go to "my network places" all i see are the files that i shared on the comp, but can't see the other computer's files. i tried "add a network place", but it couldn't find the other comp either.

Also, one comp could ping the other one, but not vice versa.

I'm connected both comps through a router (Inexq).

Any help appreciated, thxs.

BC AdBot (Login to Remove)

 


#2 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,577 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:03:31 AM

Posted 23 July 2007 - 09:48 PM

Do you have firewalls on those computers? If so, you'll need to tell each firewall about the other computer or at least the entire LAN.
Is NetBios over TCP/IP enabled just for the local computers (don't allow it for internet).
Is Workstation service running on both?
Are both computers in the same workgroup name instead of domain?
If you have different user names and passwords, are the users permitted on the opposite computer? (Unlike XP home, sharing is not limited to the gues account)

I just noticed one computer can't ping the other. Hmm, you have to solve that first before you attack sharing files.
Are the firewall settings tougher on one than the other so it doesn't respond to pings?

Run, in command prompt, ipconfig /all on both computers, perhaps it'll tell you something. They both should show the same information except for the unique IP and MAC address (Physical address).

#3 funnytim

funnytim
  • Topic Starter

  • Members
  • 624 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:31 AM

Posted 23 July 2007 - 11:20 PM

yes, i have firewalls, but i'm pretty sure they're configured to allow file sharing.

i'm not exactly sure what you mean by "netbois", or "workstation service"?

Both computers are on the same network name.

Both accounts that i'm using to setup network are administrative accounts.

As for if one of the firewall settings are tougher than the other, they might be, because one computer is newer than the other one. (It's the newer one that can't ping the older one, but they Both can't find each other's files)

Here's my IPconfig screenshots:

comp1:http://www1.filehost.to/files/2007-07-24_01/061552_ipconfig-comp1.jpg (newer comp)
comp2:http://www1.filehost.to/files/2007-07-24_01/062011_ipconfigall-comp2.jpg (older comp)

also, in my router, when i access it (http://192.168.62.1), there's a page where i can see the client's connected to it. On that page, I can only see my new computer on it, when actually both comps are connected. in other words, my older comp (the one that i can't ping using the newer one), isn't "seen" by the router, if that helps any.

thxs.

edit: the older comp can access the newer comp by going to start, run \\IP ADDRESS, but new can't see old one.

i've tried turning off windows firewall too...didnt help..

Edited by funnytim, 24 July 2007 - 12:04 AM.


#4 projectfocus

projectfocus

  • Members
  • 479 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Brighton
  • Local time:08:31 AM

Posted 24 July 2007 - 03:51 AM

I default only the shared folders are shared on the local workgroup. You will need to share the folders you wish to access across the network. You will also need to change allow users to alter files and folders if you wish to have the files moved or changed by the networked machine. I hope this makes sence.
FocusToonSigStreched.jpg

#5 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,577 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:03:31 AM

Posted 24 July 2007 - 09:44 AM

Sorry. Can't see your screen shots since they're in private storage space, prohibited at work as unsafe.
Just copy and paste text into here instead (Right click cmd window and use Edit menu to select and copy the text).
Assortment of ideas
1. In the network connections properties, obtain IP address and DHCP automatically from the router are good settings to use.
2. Did your router issue two IP addresses (correct) or are you trying to use the same static IP(wrong but likely impossible anyway).
3. What do you mean the router can't see one of the computers? That's inconsistent with 'they can both access the internet', although perhaps if not at the same time it might work.
4. Services for Workstation and NetBios and DNS client and DHCP client are in Control panel, Admin tools, Services. Make sure those services are running.
5. NetBios over TCP/IP is in the properties of the network connection, WINS section.
6. I don't know how you can tell Windows Firewall to limit NetBios to the local network. If not limited, you're vulnerable. Get a real firewall.
7. Perhaps in Windows Firewall you enabled ICS (Internet connection sharing). Since each computer is connected to a router, turn ICS off. Perhaps that's interfering.
8. Is your ISP perhaps stopping you from having more than one IP address?

9. After the network is setup, to be able to share, make sure each user of the other computer is in the user list and has permissions to directories you want them to see and act on - as projectfocus said. The concept of copying folders into shared folder is only Xp-home feature. In XP-pro just change the folder properties.

#6 funnytim

funnytim
  • Topic Starter

  • Members
  • 624 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:31 AM

Posted 24 July 2007 - 04:20 PM

ok....heres the Ipconfig /all command:

new computer: (the one that CAN be pinged BY old comp)
C:\Documents and Settings\Timothy Leung>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : leung-*******
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8168/8111 PCI-E Gigabit E
thernet NIC
Physical Address. . . . . . . . . : 00-1B-FC-1C-97-7A
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.62.138
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.62.1
DNS Servers . . . . . . . . . . . : 192.168.62.1

Old comp (the one that can't be pinged by new comp)
C:\Documents and Settings\Timothy Leung>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : LEUNG-*********
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
Physical Address. . . . . . . . . : 00-07-95-DB-1C-CF
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.62.136
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.62.1
DNS Servers . . . . . . . . . . . : 192.168.62.1


Yes, I'm using Static IP addresses, and they're both different on the comps (as listed above)

The "Netbois" client doesn't seem to be running on either comp.

But, I've enabled Netbois on both comp.

I can't find the ICS sharing in the Windows Firewall though..

Yea, they can both access the internet at the same time, but the on the router client list, it only shows my new comp, not old comp.

thxs once again.

#7 funnytim

funnytim
  • Topic Starter

  • Members
  • 624 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:31 AM

Posted 24 July 2007 - 07:34 PM

Hm....i think i've figured it out! couple of stuff:

1)I think shaw secure's firewall has been blocking the computer

2) I had a password on the guest account, and had to config my new computer to remember the password for the old one.


I shall test it, and let u guys know if i have any problems.

Thanks to everyone that helped. :thumbsup:

#8 yethPC

yethPC

  • Members
  • 365 posts
  • OFFLINE
  •  
  • Local time:02:31 AM

Posted 29 July 2007 - 02:52 AM

I do have exactly the same problem but my network setup was done via crossover cable.What seems to be unusual is that two network adapers do have different ip addresses not within the same range.One pc's ip add is 192.168.0.1 and the other one is 169.121.0.8.This is probabbly the reason why the other pc on the network not seen.How can I renew ip add of the othe pc so that itll be close to ip add of the other one?Thanks

#9 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,577 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:03:31 AM

Posted 29 July 2007 - 10:01 PM

funnytim
Cool :flowers:

yethPC
I suspect, but can't be 100% sure, that one of them is NOT connected at all.
The tipoff is the 169... address. It should show as "Limited connectivity".
If you configured the network connection, just reboot so the computer can acquire the IP address.
If it doesn't then I'd suspect bad configuration or bad network card.
Does your ISP provider permit you to have more than one MAC address hooked up? If not, you can clone one of them in the router, but I've never done it.

I don't think you'll need this, but this is the release/renew sequence. It does the same thing as the GUI 'repair connection' which for me never repaired anything :thumbsup: whereas configuration and reboot did.
ipconfig /release
reboot
ipconfig /renew if needed

Please see if something in this KB article helps
http://www.microsoft.com/windowsxp/using/n...oubleshoot.mspx
----------------------------------------------------------------------------------
Edited: I just reread your post. Crossover cable changes the picture totally or ignore my references to the router. Perhaps the first computer needs to be the dhcp server to the second one? This is beyond my skills and experience, sorry.

Perhaps this will help, I think it describes what to do in Windows just a bit above "What's next" heading.
http://www.microsoft.com/windowsxp/using/n...cutt_may29.mspx
also here, but it's long and involved
http://www.techspot.com/vb/all/windows/t-5...rk-Problem.html

Edited by tos226, 29 July 2007 - 10:23 PM.


#10 oldf@rt

oldf@rt

  • Members
  • 2,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Avondale, Arizona USA
  • Local time:12:31 AM

Posted 29 July 2007 - 11:58 PM

yethPC

is a router involved in your setup?, if there is you cannot use a crossover cable, you must use standard (IEEE568A or B ) network cable. the 169.121.0.8 ip says that your card cannot talk to the DHCP server, and the address is provided by the card itself.

Thanks, OF

Edited by oldf@rt, 29 July 2007 - 11:58 PM.

The name says it all -- 59 and holding permanently

**WARNING** Links I provide might cause brain damage

#11 yethPC

yethPC

  • Members
  • 365 posts
  • OFFLINE
  •  
  • Local time:02:31 AM

Posted 10 August 2007 - 06:09 AM

I can now see these two computers in every client PCs but the problem is that there was somethning that blocking me to access the other computer from the computer I was using as I was sayin g that I am not permitted.When I try to open PC1 from PC2 , it was saying not accessible.Thanks for your suggestions

#12 funnytim

funnytim
  • Topic Starter

  • Members
  • 624 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:31 AM

Posted 28 November 2007 - 02:55 PM

maybe u have a firewall on?
or, check window's built-in one.

#13 Cyb3r_Ninj@

Cyb3r_Ninj@

  • Members
  • 169 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Silicon Valley
  • Local time:12:31 AM

Posted 13 December 2007 - 01:18 PM

I'd make sure that your user account is configured the same way on each system, since the Security Accounts Manager on each system is exclusive to the Local Machine only. You may have administrative permissions on one machine, but not on the other, or vice versa. You'll want to also make sure that your user account is configured as part of the Local Administrators group on both computers, that should grant you permission to access each computer with administrative permissions.
***********************************************************************
Bill Gates recognizes the skills... so i suggest you start there and recognize them too...
***********************************************************************
:: digital.ronin ::

| MCP - ID 5646435, other certifications pending... |




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users