Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Default Browser Keeps Changing


  • This topic is locked This topic is locked
18 replies to this topic

#1 applesauce1234

applesauce1234

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:06:46 AM

Posted 27 May 2006 - 12:17 PM

Hi there

I recently switched from Internet Explorer 6.0 to the newest version of Firefox. However, I am unable to change the default browser from being IE6.0...

things I have tried:

- seleting the option "Firefox should be the default browser"
- seleting the option "Firefox should check to see if it the default browser"
- deselecting the IE option "IE should check to see if it is the default browser"
- uninstalling an item called "Internet Explorer Default Browser" from Add/Remove Program
- changing how files open through my computer... file/tools/folder options/open htm/html with Firefox
- restarting computer

If I go into the firefox options and click "Check Now" to see if it is the default browser, a message comes up saying it is not... it then asks me if I want to change it. I click yes, and then click "Check Now" again, but the message still comes up, even if I restart the computer.

It just will not save my preference. Im guessing that somewhere there is a setting that I chose that made IE the default browser and must be deactivated... but I cant find it...

I have Windows XP, use Sunbelt Kerio Firewall, AVG Free and Spyware Guard.

Thanks a lot! Any help would be greatly appreciated!

Colin Weadick
XXXXXXXXXXXXXXX

(Moderator edit: E-mail address deleted to protect member against spybot harvesting. jgweed)

Edited by jgweed, 27 May 2006 - 01:23 PM.


BC AdBot (Login to Remove)

 


#2 Elendil

Elendil

  • Members
  • 660 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The US
  • Local time:07:46 AM

Posted 27 May 2006 - 01:50 PM

There are several issues that could be the problem here. The first one is: You must be on your administrator account to make Firefox your default browser. Another method of making Firefox your Default Browser is to do the following: Open up your control panel, launch the Add/Remove Program, click on the Set Program Default and Access tab, select the Custom Tab, Under your default Web Browser, select Mozilla Firefox, and then click Ok.
Stanford '14
B.S. Candidate | Computer Science

#3 applesauce1234

applesauce1234
  • Topic Starter

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:06:46 AM

Posted 27 May 2006 - 02:21 PM

Thanks for the reply...

I tried restarting my computer and going into safe mode (so that I could access the adminstrator login... if i just try and log off in regular windows mode, it says I am the only user... i guess i enabled it so that I am the administrator)... anyway, i changed the settings in add/remove programs/set program, but it just says that it is applying the changes, and then it just sits there, and keeps saying that it is applying the changes, until i hit cancel...

if i attempt to do this in regular windows mode, under the non-admin login, it still happens... everytime i open FireFox, it asks me if I want it to be the default browser, and I click yes.

i dont seem to be able to access the administrator login, while still being able to access the internet (i.e. I can only access admin login in safe mode)... does that make a difference?

If I am in MSN Messenger, and I try and check my email from it, it will open up IE... but if, say, I am in WordPerfect, and I type a URL, it will open that URL with FireFox.

Any more ideas?

colin weadick

#4 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:05:46 AM

Posted 27 May 2006 - 04:13 PM

See if the solution here, works for you:
Use FireFox as the default browser to open links in Outlook
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#5 applesauce1234

applesauce1234
  • Topic Starter

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:06:46 AM

Posted 28 May 2006 - 01:25 AM

Thanks for the tip

Unfortunately, it didnt seem to work... when i try and edit any of the file types, I click OK, but it never saves what I edited...

(NONE) URL: HTTP was already set for using FireFox, but I noticed that (NONE) URL: HTTP with Privacy is set for IE, and as I said, I cant change it... it wont save... its the same deal with (NONE) Internet Shortcut... it is edited as using IE, and will not change

Could this maybe be a registry problem?

Any more ideas, anyone?? :thumbsup:

#6 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:05:46 AM

Posted 28 May 2006 - 02:21 AM

It could be a corrupt install, of Firefox.
I'd try a simple reinstall.
You won't loose any of your settings, or bookmarks.
Those are stored in a different folder, that isn't removed with an uninstall.

Delete Firefox using Add or Remove Programs.
Go to C: / Program Files, and delete the Mozilla Firefox folder.
Download a fresh copy of Firefox.
Now, reinstall Firefox.

If that doesn't work, the only other thing I can think of, would be a complete uninstall/reinstall.
Let me know if the above doesn't work, and I'll post the instructions.
It a little more involved, but easy.
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#7 applesauce1234

applesauce1234
  • Topic Starter

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:06:46 AM

Posted 28 May 2006 - 03:26 AM

Nope, still didnt work!

Are you sure that there are no more settings that need to be set to FireFox, and not IE?

Colin Weadick

#8 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:05:46 AM

Posted 28 May 2006 - 12:42 PM

There's only one setting in Firefox, and you've already tried that.

Something in your Profile folder could be corrupt.
Here's the directions for a clean uninstall/install, if you want to try it.

Note: You will have to go back and redo all of your personal settings (Options), as deleting the Profile folder will erase everything Firefox related.
You will be starting with a clean slate.

To completely uninstall Firefox, you will need to delete your Profile folder.
This file is not removed when you uninstall Firefox from Add/Remove.
It will retain all of your previous settings, and re-apply them to your new install, if it's not deleted.
That's why, when you install a new version of Firefox, your previous settings, bookmarks, passwords, etc., all remain the same.
For a Fresh (start from scratch) install, this folder has to be removed.

You might want to make a copy of the Bookmark.html file, before you uninstall, and save it to somewhere you'll be able to find it.
This is where all of your Bookmarks are stored.
Set windows to show hidden files,
How to see hidden files in Windows
Then navigate to:
C:\ Documents and Settings \ user name \ Application Data \ Mozilla \ Firefox \ Profiles \ default.random characters \ Bookmark.html
And make a copy of the Bookmark.html file

Then you can replace, the new one created, with the old one, you copied.
After you install Firefox, delete Bookmark.html, and replace it with your saved copy of Bookmark.html.
That way, you'll have all of your Bookmarks back.

Now for the uninstall.
Uninstall your current version of Firefox from Add/Remove programs.
Then navigate to:
C:\ Documents and Settings \ "your user name" \ Application Data \ Mozilla \ Firefox \ Profiles
Delete the Profiles folder (or send it to the Recycle Bin as a backup).
Then navigate to:
C: \ Program Files \ Mozilla Firefox, and delete that folder.
Then reinstall Firefox.

Don't forget to replace your Bookmark.html file.
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#9 applesauce1234

applesauce1234
  • Topic Starter

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:06:46 AM

Posted 28 May 2006 - 01:32 PM

Ok... I made a copy of bookmarks.html, and then did as you said to uninstall and delete Firefox... i then reset the computer... using IE, i then downloaded the newest firefox... it installed fine, but when i try and launch firefox for the first time, this message comes up:

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your computer.

Using HiJackThis, I couldnt find any incidences of Firefox already open, soi reset my computer, but the problem is still there. strange huh?

Colin

#10 applesauce1234

applesauce1234
  • Topic Starter

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:06:46 AM

Posted 28 May 2006 - 01:45 PM

well, i just re-uninstalled it again, and now i can access firefox... BUT, the problem is still there... everytime i open FireFox, it asks me if i want it to be the default browser, to which i always say yes.

#11 buddy215

buddy215

  • BC Advisor
  • 5,885 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:06:46 AM

Posted 28 May 2006 - 01:46 PM

What is your IP? Is it Netzero or one of the the other 2 associaed with? One is Juno and I can't think of the other.

“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”
Lawrence M. Krauss


#12 applesauce1234

applesauce1234
  • Topic Starter

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:06:46 AM

Posted 28 May 2006 - 01:52 PM

Hey There

No, I use Bell Sympatico.. everything works pretty well with it...

#13 buddy215

buddy215

  • BC Advisor
  • 5,885 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:06:46 AM

Posted 28 May 2006 - 01:56 PM

the reason I asked is because you can't set Firefox as default browser in Net000000. You might check with Bell.

“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”
Lawrence M. Krauss


#14 applesauce1234

applesauce1234
  • Topic Starter

  • Members
  • 188 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:06:46 AM

Posted 28 May 2006 - 02:12 PM

hmmmm

does anyone else think thats it? can the ISP control which default browser I use?

i think its interesting that I am unable to change anything that tj1911 suggested through this link:

http://www.slipstick.com/problems/firefox.htm

none of the changes I make will save

colin

#15 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:06:46 AM

Posted 28 May 2006 - 10:35 PM

Open the control panel and see if you have an administrator account.
You cannot make system changes with a limited account.

You should not have to use safe mode to access an admin account. You should be able to logon to it in normal mode.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users