Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Keyboard does not pop up automatically


  • Please log in to reply
6 replies to this topic

#1 dragonbrain

dragonbrain

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:12:21 AM

Posted 31 December 2012 - 12:55 PM

A keyboard icon shows on task bar but I must manually touch. I am referring to an automatic pop up when in a text box (in desktop, not on Metro where it does pop up). In Win 7 the keyboard always pops up but MS changed the setting for Win 8 - thought I might get some insight here. I have seen googled and seen other posts on this topic - I am running Win8 on a Samsing ATIV tablet

BC AdBot (Login to Remove)

 


#2 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,917 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:11:21 PM

Posted 01 January 2013 - 01:18 PM

Hi

There are still so many things in Windows 8 that feel like I am doing unnecessary extra clicks because I don't know all of the tricks yet.

This was one of them :)

I'm glad to see that this may be one that is not due to my ignorance of the interface.

I wonder if there might be a registry setting that governs the behavior of the on-screen keyboard when working on the desktop?

If I find anything, I'll post it here, please do the same.

James

#3 dragonbrain

dragonbrain
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:12:21 AM

Posted 01 January 2013 - 02:18 PM

No, you aren't alone - I am also looking in the registry - do you have any clue where the keyboard resides?

#4 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,917 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:11:21 PM

Posted 01 January 2013 - 09:20 PM

I'm not sure where something like that would be in the registry. The more I think about what it would need to do the more I understand the problem with doing it.

The thing is that as an app it can be that the OS is set to automatically popup the virtual keyboard when an editable XAML control like a textbox fires the GotFocus event if there is no physical keyboard.

In the desktop however, you are not dealing with apps so the textbox often is probably not an XAML control so it does not have the same wiring for the event. I would not be surprised if there is some difficulty making this behavior consistent in non-XAML controls for some reason that I am not aware of.

James

#5 Grinler

Grinler

    Bleep Bleep!


  • Admin
  • 40,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:12:21 AM

Posted 02 January 2013 - 12:41 PM

I have been looking into this as well. The touch keyboard is launched using this executable and command line on my surface tab:

"C:\Program Files\Common Files\microsoft shared\ink\TabTip.exe" /QuitInfo:0000070C;00000738;

In the past the automatic popup feature in Win 7 was controlled by the Registry value:

HKCU\Software\Microsoft\TabletTip\1.7\ShowIPTipTarget = =dword:00000001

Unfortunately, this setting does not work in Windows 8.

#6 dragonbrain

dragonbrain
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:12:21 AM

Posted 02 January 2013 - 03:26 PM

I found a good workaround (Comfort Keys from http://www.comfort-software.com/ - works flawlessly but cost $30 which pisses me off to pay for something that MS should fix)

#7 Grinler

Grinler

    Bleep Bleep!


  • Admin
  • 40,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:12:21 AM

Posted 02 January 2013 - 03:31 PM

Thanks for sharing the solution. I agree...not sure why they made this change and we are not the only ones complaining about it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users