Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Microsoft Word-Spacing between words


  • Please log in to reply
22 replies to this topic

#1 HamSandwich

HamSandwich

  • Members
  • 60 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Georgia
  • Local time:01:53 PM

Posted 16 June 2011 - 06:43 PM

I have been looking for an answer to this question for a few weeks now. I unfortunately have not found anything that covers the specific aspect of Word I am discussing.

In Word 2010 (I think 2007 did the same thing), the spacing between words is different depending on the words and how they fit together on the line. I assume that Word is automatically trying to fit as much information on one line as possible by adding or subtracting small amounts of space (smaller than what the spacebar can do) between words. I understand the purpose of this, but it is getting very distracting and confusing in my written pieces. For example, some words look almost as if they are one large word (e.g. 'teaching position' looks like 'teachingposition' because of the small amount of space between the two words) while others look as if a small word (like 'a' or 'I') could possibly fit between them (e.g. 'teaching [ ] position'). This creates a strange looking set of words across a line when the spacing is different between each word.

I have looked up and attempted to execute line spacing and character spacing to no avail. I have no problem with single and double spacing nor the spacing between characters within the same word. I am only having an issue with the distance between the words themselves. I do not want Word automatically adjusting the spacing between words in order to make a "pretty" line of words. I would rather like a fixed rate at which words are spaced.

As I said, I have looked this up for weeks trying different search queries and different combinations of terms to try and find what I am looking for. However, all I get is character and line spacing troubleshooting, which is not what my problem is.

Does anyone have a good idea why Word does this (as it apparently does it by default) and how to turn it off?

Edited by HamSandwich, 16 June 2011 - 06:54 PM.


BC AdBot (Login to Remove)

 


#2 Murtle the Turtle

Murtle the Turtle

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Detroit Metro Area
  • Local time:01:53 PM

Posted 17 June 2011 - 01:43 PM

You have your paragraph set to 'Justify' which means to stretch out the text to fill the entire space within the margin so all rows of text are exactly the same length. To fix it, the first thing you need to do is select all the text in the document. My quick easy way to do this is to press these keys one after another, not holding them all down at the same time: Alt-E-L.

Then on the home tab in the Paragraph box you can click the 'right align' button. The shortcut for this is Ctrl-L (Press the L key while holding down the Ctrl key.)

#3 HamSandwich

HamSandwich
  • Topic Starter

  • Members
  • 60 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Georgia
  • Local time:01:53 PM

Posted 17 June 2011 - 02:50 PM

Thank you for the advice!

However, this has not directly fixed the problem I'm having, that the spaces between words are different.

The document is set to 'left justified'. If I set it to 'right justified', everything is reversed to the right side. However, the spaces still remain at different lengths between words. Same with just doing plain 'justified'--Word sets the length of the spaces according to how many, and the length of, words on the line.

In the same way that 'left justified' did it, there are spaces that look much larger and much smaller than others between different words. Is there any way to simply turn off justification so that there is a static amount of space between all words that never changes no matter how many, or the length of, words on a line?

If I can't get around this, it's fine, only that I think it looks a little strange and it draws my eye to it.

Edited by HamSandwich, 17 June 2011 - 02:56 PM.


#4 strolln

strolln

  • Members
  • 400 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:N. Calif.
  • Local time:10:53 AM

Posted 17 June 2011 - 03:06 PM

You could try using a monospaced font like Courier. Why do you need to justify the text? Do things look OK if you don't use justification?
To Err is human; to really foul things up requires a Bleeping Computer!

#5 HamSandwich

HamSandwich
  • Topic Starter

  • Members
  • 60 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Georgia
  • Local time:01:53 PM

Posted 17 June 2011 - 03:44 PM

Is there some way to apply Courier rules to Times New Roman, i.e. can I use Times New Roman without justification? If so, how can I accomplish this in Word? I cannot find how to entirely omit using justification in Word. There does not seem to be a way to simply turn it off.

Edited by HamSandwich, 17 June 2011 - 03:44 PM.


#6 petewills

petewills

  • Members
  • 1,344 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:53 PM

Posted 19 June 2011 - 11:38 AM

This is what I would have to do in Word 2003. Is it a similar process in Word 2010.

My text is set to left aligned.

To change the width of the space between the words I would change the font settings of the text.
You can do this by selecting the text, right click on text and click Font, then go to the advanced tab
where you can change the character spacing settings. (Character spacing / spacing).

I have to say that just selecting the left alignment gives me perfect spacing between words;
can't remember ever having to fiddle around with these extra settings.

(Checked it out again in Times New Roman).

Ignore, if this adds nothing to the above posts. :)

#7 Orange Blossom

Orange Blossom

    OBleepin Investigator


  • Moderator
  • 33,550 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Bloomington, IN
  • Local time:01:53 PM

Posted 19 June 2011 - 03:25 PM

Justification has to do with vertical alignment. If you are left-justified, you will have a straight line on the left edge. If you are right-justified, you will have a straight edge on the right. What you want to avoid is the type of justification that aligns both edges. That makes both the left and right edges perfectly vertical, but the spacing between letters and words gets very odd. At times it will be very tight and others stretched out. This is the first setting I check when I have spacing issues.

Sometimes the font type will affect word and letter spacing. I have sometimes found the spacing to be too close between letters. For some reason, the program allows less space after, for example, an l than after an e or an s. Sometimes I fixed it on a letter by letter basis within the document, but that is time consuming. Changing the character spacing within the font itself seems to help, or simply choosing a different font.

Orange Blossom :cherry:

edited to add: In fact, I can see the decreased spacing after the l's in this post.

Edited by Orange Blossom, 19 June 2011 - 03:28 PM.

Help us help you. If HelpBot replies, you MUST follow step 1 in its reply so we know you need help.

Orange Blossom

An ounce of prevention is worth a pound of cure

SuperAntiSpyware, SpywareBlaster, WinPatrol Plus, ESET Smart Security, Malwarebytes' Anti-Malware, NoScript Firefox ext., Norton noscript


#8 HamSandwich

HamSandwich
  • Topic Starter

  • Members
  • 60 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Georgia
  • Local time:01:53 PM

Posted 19 June 2011 - 03:43 PM

This is what I would have to do in Word 2003. Is it a similar process in Word 2010.

My text is set to left aligned.

To change the width of the space between the words I would change the font settings of the text.
You can do this by selecting the text, right click on text and click Font, then go to the advanced tab
where you can change the character spacing settings. (Character spacing / spacing).

I have to say that just selecting the left alignment gives me perfect spacing between words;
can't remember ever having to fiddle around with these extra settings.


My text is left aligned, as well--however, there is still awkward spacing going on. The character spacing option does not help with word spacing, as far as I can tell. Rather, it expands or condenses the space between all characters, not just between words. Even then, i'm not sure that character spacing would allow me to set a standard spacing between all words. I vaguely remember some option in an older version of Word that allowed the user to let Word make spacing "prettier" or not...

Justification has to do with vertical alignment. If you are left-justified, you will have a straight line on the left edge. If you are right-justified, you will have a straight edge on the right. What you want to avoid is the type of justification that aligns both edges. That makes both the left and right edges perfectly vertical, but the spacing between letters and words gets very odd. At times it will be very tight and others stretched out. This is the first setting I check when I have spacing issues.

Sometimes the font type will affect word and letter spacing. I have sometimes found the spacing to be too close between letters. For some reason, the program allows less space after, for example, an l than after an e or an s. Sometimes I fixed it on a letter by letter basis within the document, but that is time consuming. Changing the character spacing within the font itself seems to help, or simply choosing a different font.


How would I fix spacing letter by letter, especially if one press of the spacebar puts a large space? I don't think there is any way to make a smaller space than one press of the spacebar. Unless I just expand all of my spaces, in which case you're right, it would be very time consuming.

Also, would you have any other fonts in mind that would have set spacing? Courier is ugly to me, so anything similar to Times New Roman would be great. If this is a "feature" of Times New Roman, then I can't really change that.

#9 Allan

Allan

  • BC Advisor
  • 7,832 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:53 PM

Posted 19 June 2011 - 03:48 PM

Just a silly question please. Are you talking about what you see on the screen or how it prints (or are both exactly the same)?

#10 Orange Blossom

Orange Blossom

    OBleepin Investigator


  • Moderator
  • 33,550 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Bloomington, IN
  • Local time:01:53 PM

Posted 19 June 2011 - 04:00 PM

How would I fix spacing letter by letter, especially if one press of the spacebar puts a large space?


Note that I have MS 2003, so pathways may be different for your version.

Highlight the letter in question, click on Format then Font then character spacing. You can experiment there.

Usually, I've done it only when letters mash into each other and it's difficult to tell that it's two different letters and not just one, for example, when r and n are mashed together so that it looks like an m.

If you don't highlight any text, but follow the same pathway, you can adjust the spacing between all the letters simultaneously. All the letters will then have the same amount of space added or subtracted before or after depending on what you are doing. There is a preview pane so you can see the effects. At least, that is the case in MS 2003.

Orange Blossom :cherry:

Help us help you. If HelpBot replies, you MUST follow step 1 in its reply so we know you need help.

Orange Blossom

An ounce of prevention is worth a pound of cure

SuperAntiSpyware, SpywareBlaster, WinPatrol Plus, ESET Smart Security, Malwarebytes' Anti-Malware, NoScript Firefox ext., Norton noscript


#11 HamSandwich

HamSandwich
  • Topic Starter

  • Members
  • 60 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Georgia
  • Local time:01:53 PM

Posted 19 June 2011 - 04:21 PM

Just a silly question please. Are you talking about what you see on the screen or how it prints (or are both exactly the same)?


This is strange. I just printed it out and compared some of the obvious spacing spots. The printed copy does not seem to have problems in the same areas. It is only on the screen that there appears to be spacing issues, unless my eyes are just deceiving me...

If you don't highlight any text, but follow the same pathway, you can adjust the spacing between all the letters simultaneously. All the letters will then have the same amount of space added or subtracted before or after depending on what you are doing. There is a preview pane so you can see the effects. At least, that is the case in MS 2003.

Orange Blossom :cherry:


Character spacing doesn't help. I just tried it again, and I'm not happy with the way it looks. Presumably, I guess, if Word is deciding how to fit words together on a line in a "prettier" fashion by spacing them differently, then condensing and expanding them would affect that. However, overall, I only like the standard character spacing. :wink:

#12 Allan

Allan

  • BC Advisor
  • 7,832 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:53 PM

Posted 19 June 2011 - 04:25 PM


Just a silly question please. Are you talking about what you see on the screen or how it prints (or are both exactly the same)?


This is strange. I just printed it out and compared some of the obvious spacing spots. The printed copy does not seem to have problems in the same areas. It is only on the screen that there appears to be spacing issues, unless my eyes are just deceiving me...

That's what I thought. I wouldn't spend a lot of time worrying about it then.

#13 HamSandwich

HamSandwich
  • Topic Starter

  • Members
  • 60 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Georgia
  • Local time:01:53 PM

Posted 19 June 2011 - 04:35 PM

That's what I thought. I wouldn't spend a lot of time worrying about it then.


Do you know why it does this?

#14 Allan

Allan

  • BC Advisor
  • 7,832 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:53 PM

Posted 19 June 2011 - 04:39 PM

Variations in screen sizes, video cards - display abilities in general - from system to system. "What you see is what you get" isn't always the case :)

When all is said and done, all you care about is what it looks like on paper, right? So as I suggested, don't spend a lot of time worrying about it ;)

#15 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,447 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:01:53 PM

Posted 20 June 2011 - 12:35 PM

Just for the heck of it, try deleting the normal.dot and normal.dotm files.
See here for instructions
In the beginning there was the command line.




5 user(s) are reading this topic

0 members, 5 guests, 0 anonymous users