Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Error loading c:\windows\system32\newdev.dll


  • Please log in to reply
1 reply to this topic

#1 ChipJen70

ChipJen70

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:14 AM

Posted 11 April 2009 - 06:01 AM

Hiya all

I'm new here and I was wondering if someone has any idea what I can do with my PC... I have a DELL Dimension E521 and I am using Windows Vista Home Premium OS.

I was on 'lovely' Facebook yesterday (Friday 10th April 2009) and the PC froze. I had to switch it off by pressing the on/off button, and when I re-booted, I logged in and it loads (slowly) but takes me to a blank screen with only my mouse pointer on it (it moves around).

A message appears with the following information:


"Error loading c:\windows\system32\newdev.dll

A dynamic link library (DLL) initialisation routine failed."

I can press CRTL+ALT+Delete and it takes me to the 'lock computer, etc' page and I can restart the PC, but the same thing happens.

I have run multiple scans through pressing F12 on restart, I can enter the PC in Safe Mode by turning the PC off at the wall and restarting it (it's what I'm using now).

I have downloaded Reg Cure (but it asked me to pay money) and HiJack This but bit nervous about using it myself without instruction.
I have also downloaded and run a scan through Malwarebytes from a link I got through this site, I'll post the results upon request but not sure what they mean (obv!).

My McAfee won't work during Safe Mode and I've run a thorough scan with this, too but nothing shows up. I am at risk at the moment as I am not protected, and when I click 'Fix' in McAfee, it gives me the error message:
"One of more problems cannot be fixed because of an error."

I Googled the above 'newdev.dll' message and I found a replacement 'newdev.dll' file, but as I am in Safe Mode my PC won't let me replace the file.

I would also like to back up my files to an External Hard Drive to see if I can re-install my operating system and Drivers as I am worried if I do, I'll lose all my files. I can't do this in Safe Mode.

I think this is all the information I have so far. Please, if anyone can help me, let me know what else I can tell you.

Thanks in advance.

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:12:14 PM

Posted 12 April 2009 - 08:44 PM

I Googled the above 'newdev.dll' message and I found a replacement 'newdev.dll' file, but as I am in Safe Mode my PC won't let me replace the file.


You would be better off getting the file of a Windows CD or out of you i386 folder
Run SFC.exe
See if you can borrow a retail Windows CD from somebody
http://www.bleepingcomputer.com/forums/t/43051/how-to-use-sfcexe-to-repair-system-files/


Update mbam and run a FULL scan
Please post the results
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users