Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Vista Home Premium Desktop Icons Disappear On Startup


  • Please log in to reply
15 replies to this topic

#1 brodes

brodes

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:07 PM

Posted 04 September 2008 - 11:06 PM

Hi, I'm new here.

I have just purchased a new Asus M51VR notebook with Vista Home Premium SP1 pre-installed & all Windows updates downloaded. All working well so far (my first experience with Vista) except whenever I restart Windows my desktop icons appear briefly then disappear. This only happens with my desktop icons - my taskbar & gadgets are all visible. I can right-click on my desktop & in the "view" sub-menu I uncheck then check "Show desktop icons" & my icons re-appear - until I restart Windows again & they disappear again. I have tried another method by closing the "explorer.exe" process in task manager, then opening the DOS window & deleting the "iconcache.db" file in "C:\Users\****\AppData\Local" folder, then restarting explorer (re-building the "iconcache.db" file) & my icons re-appear :huh: - until I restart Windows :huh: . The only other way I can access my "invisible" desktop icons is by enabling the desktop toolbar on the taskbar, but this will not do. I have also installed, updated & run latest versions of Spybot & SUPERAntiSpyware with nil results. I have downloaded HijackThis but have not run it yet, as I am not that confident enough with Windows processes.

I believe another process may be interfering on startup, by the manner in which the icons appear briefly then disappear as all the startup processes load? Or is it a simple Vista glitch with the explorer shell?

Any help appreciated.

Regards.

EDIT - I think I have solved the problem. I checked my power icon in the system tray & changed the Asus Power4Gear power-plan to "Power4Gear high performance" from "Power4Gear quiet office" & my icons re-appeared. I have just tested this again a couple of times, done a couple of restarts & it seems to be the fix. Not sure why though?

Edited by brodes, 05 September 2008 - 09:05 AM.


BC AdBot (Login to Remove)

 


#2 TC.DN.NZ

TC.DN.NZ

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:07 PM

Posted 25 January 2009 - 12:04 AM

Hi brodes

I also recently got an ASUS M51V Series notebook with Window Vista pre-installed. I have been going round the bend trying to solve this :huh: - so thanks for the updated post - your solution worked prefectly :huh: . I hadn't changed the power settings (but my 5 yr old was playing on it - so I'm guessing he somehow changed it). I'm also guessing (I don't know much about the technical side of computing) that the other setting must stop all "unnecessary" power usage, and that may be why the icons disappear.

Edited by TC.DN.NZ, 25 January 2009 - 12:05 AM.


#3 Brightside_103

Brightside_103

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 22 February 2009 - 07:37 PM

I also recently got a new ASUS notebook computer (Series F3Q) with Windows Vista Business pre-installed and had precisely the same problem with desktop icons disappearing. I also could get the icons to reappear by unchecking and rechecking the 'Show Desktop Icons' in the 'View' menu when you right click on the desktop. But they'd disappear again after changing users or re-booting. This problem was driving me bananas.

I tried the solution of changing the power settings in the ASUS Power4Gear power-plan to "Power4Gear high performance" from "Power4Gear quiet office" & my icons re-appeared. I've tested the fix through re-booting, switching users, etc and it seems to work reliably. :huh:

I also don't understand why changing the power setting should cause the desktop icons to disappear/reappear. At first I thought this must have been a Windows Vista problem. But I now think it is more likely an ASUS problem. When I had the problem, the desktop icons would appear briefly on powering up the laptop and then disappear when the ASUS Splendid Video Intelligence Technology software icon appeared on screen during the computer start up sequence. The ASUS Splendid Video Intelligence Technology software includes the Power4Gear setting software. So while my overall initial reaction to Windows Vista is very negative, I don't think we can blame Microsoft for this one. :huh:

#4 mister_apocalypse

mister_apocalypse

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sale, VIC, Australia
  • Local time:05:07 PM

Posted 22 March 2009 - 08:32 PM

Hi,
I do a fair bit of work on these Asus notebooks, and have found the solution to this problem.
It works OK to simply enable a different power plan, but if the current plan suits your needs more than others, it is a simple fix.

-Right click the Power icon in the system tray
-Select Power4Gear Extreme
-Click continue on the UAC prompt
-Make sure the 'Quiet Office' plan is selected
-In the lower right corner, there is an option to 'Hide Desktop Icons'. Set this to No and your problems are solved.

Hope this helps someone! :huh:

Mister_Apocalypse

#5 cart0181

cart0181

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:02:07 AM

Posted 25 March 2009 - 11:10 PM

First of all, let me say THANK YOU SO MUCH for figuring out this solution. :huh: I know people sort of stumbled upon this fix (you would have to) but YOU'RE A GENIUS anyway. Now I can move on with my life, and so can my client (it's their PC). You saved me from yet another quirky problem which is ruining my life lately.

SEE BELOW FOR RANT: :huh:

Pardon my French, but WHY THE H*** would ASUS do something like that with their Power4Gear software?!?! Good GOD. This took me SOOOOOO F'ing long to figure out. And I'm a PROFESSIONAL! Man, I'm going to write a nasty letter to ASUS or whoever I find out programmed that piece of crap software. It was IDIOTIC to set that up as the DEFAULT power profile and to have icons disappear by DEFAULT!? How low does their IQ have to be to set it up like that? Is that supposed to be some kind of SICK JOKE or something?? Disgruntled software programmers I tell you. Foisting this c*** on an unsuspecting un-savvy public is such a crime. :huh:

Edited by usasma, 26 March 2009 - 07:32 AM.
see ***'s


#6 Mudskunk

Mudskunk

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:07 AM

Posted 30 April 2009 - 10:34 AM

i got my ASUS M70 laptop yesterday and was having the same frustration. but fortunately it was quit obvious that i knew exactly what to do sicne the behaviour made total sense that the icons disappearing was due to power saving!! but seriously i found the answer only after looking for hours and finally came here and there was the answer in this post. shoulda come here first instead of using that damn google. sorry google i dont wanna buy icons from amazon!!

#7 KMW

KMW

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Location:Perth Western Australia
  • Local time:03:07 PM

Posted 08 May 2009 - 08:34 AM

Hello fellas, had the same problem myself until I stumbled across this thread online.
Problem solved now thanks to Mister_Apocalypse, I used your method, easy.
Was seeking help in another forum I frequent,
copied your solution into the thread there marking it solved
giving you the credit for the solution
techguy.org/windows-vista-7



Ha, went to register as a new member here so I could reply only to find I'd been a member since 2006. forgot about that :huh: All I can say is I'm a real quiet fella, this is my first post here, at this rate I'll have 300 posts in 3000 years. I'll be a bit long in the tooth by then :huh:

Edited by KMW, 08 May 2009 - 08:38 AM.


#8 brtl

brtl

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:07 AM

Posted 10 May 2009 - 04:55 PM

Mister_Apocalypse, I've just registered with this forum for no other reason than to say thank you, and to put some of the stuff below in as a google hint to whoever else has to suffer this interesting problem.

Maybe I'm losing it, it's been years since I did regular windows support, but I'd been installing and configuring this fresh Asus F6V laptop with windows vista home premium. At the very end of getting everything in place (having last experienced a crash of sorts after it had suspended itself when the battery finally drained) including an old HP driver for the 2575 all-in-one printer/scanner (printing worked fine with the vista supplied driver but the scanner wasn't detected).

So I had started suspecting all kinds of ghosts (vista in general, services, oldish HP driver) when I finally stumbled across this page, via Google. I couldn't agree more with cart0181's rant, there doesn't seem to be any value in disabling icons as part of a performance/power profile. One of the better 'its not a bug, its a feature' puzzles I've come across recently though. Let's hope Asus will fix this interesting feature - going to try and create a bug report with them now.

Thanks again, brodes too,

-Bert, Amsterdam

#9 Bursin

Bursin

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:07 AM

Posted 22 July 2009 - 05:51 PM

Ahh, what a relief.. Finally problem solved thanks to you :huh:

I have a N51V my self and this thing has been bugging me for a WHILE now and worst of all: It was set to "Quiet Office" and my Processor was set to like 20-30 %. Finally I can fully enjoy my computer :huh:

Ps. I registered for this post, that's how much it means to me, thanks again ^^

#10 semicomic

semicomic

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:07 PM

Posted 21 August 2009 - 12:07 AM

Thanks so much Mr. Apocalypse! This problem has been bugging me for months. I thought it was probably an ASUS deal instead of Vista. I kept looking at all the Splendid display settings to no avail. Great catch!!!!

#11 lzywayz

lzywayz

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:07 AM

Posted 22 September 2009 - 10:55 AM

On an Asus you normaly you run in Entertainment mode, but it's easy to hit the little guy or a function key to switch to Office Silent Mode. In Office Silent Mode it will not display desktop icons. Do not know why, probally if using in this mode, would probally being using projector or something. Either way, just change to a different display mode and you shold be good to go.

You can go to Control Panel, double click on Power Options and click on Power4Gear eXtreme on the left. From here you can adjust different settings for each mode and for both battery and AC conditions. You can also click on Advanced Settings and make lots more changes.

If this does not work, right click on desktop, go to View and make sure Desktop Icons is checked. You can uncheck and recheck, sometimes this fixes things.

If none of this works, there are other great ideas on this and other sites. Good luck!!

#12 tommyt1971

tommyt1971

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:07 AM

Posted 14 June 2010 - 10:51 PM

Hi,
I do a fair bit of work on these Asus notebooks, and have found the solution to this problem.
It works OK to simply enable a different power plan, but if the current plan suits your needs more than others, it is a simple fix.

-Right click the Power icon in the system tray
-Select Power4Gear Extreme
-Click continue on the UAC prompt
-Make sure the 'Quiet Office' plan is selected
-In the lower right corner, there is an option to 'Hide Desktop Icons'. Set this to No and your problems are solved.

Hope this helps someone! :huh:

Mister_Apocalypse


MANY THANKS!!! This worked beyoooootifully!!!! :huh: :huh:

#13 Captain Nick

Captain Nick

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:02:07 AM

Posted 11 January 2011 - 12:31 AM

Please add my thanks for this fix. I had tried twice over two weeks to find the solution. :thumbsup:

#14 stink1986

stink1986

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 16 March 2011 - 08:22 AM

:thumbsup:

Thank you so much for the info guys -been going arround chasing my tail in circles for the last two days because of this!!! Would never have gotten to the bottom of it otherwise! Cheers!

#15 M@@r

M@@r

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:07 AM

Posted 03 June 2013 - 05:07 AM

Mister_Apocalypse,

 

"Hope this helps someone!" - that's pretty modest! I am yet another person that just joined this forum in order to thank you for posting this great solution to a problem that has been keeping me searching for a solution for a long time.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users