Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How To Disable Ip Address Conflict Popup


  • Please log in to reply
10 replies to this topic

#1 Verywierd

Verywierd

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:06 AM

Posted 12 March 2008 - 09:22 AM

Hello,

I did try searching the forum first, but the search refused to accept a two letter word "IP" as a search parameter.

Does anyone know how to disable permanently the windows popup warning regarding IP Address Conflict system errors?

I have a single notebook connected to the internet via an ADSL line (not wireless). There is no other machine or device (router etc). The popup is intermittent and does NOT interrupt the internet connection. In fact, there is no visible effect at all. However, the popup is extremely annoying. From what I have found on the net, it is likely that the ISP is issuing duplicate IP's, although that is just a guess. It is not a virus or trojan. I have re-formatted my HD and re-installed WinXP and still get the warning.

All I want is a way to get rid of the pop up. I have tried edting the registry to turn off all the "show tip" options as recommended by some guides, but the popup still comes.

Any help would be most appreciated.

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:03:06 AM

Posted 12 March 2008 - 01:35 PM

Are you behind a router or using a VOIP phone service?
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 Verywierd

Verywierd
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:06 AM

Posted 12 March 2008 - 04:08 PM

No. Dead simple direct pc to adsl modem setup via ethernet cable. No router, no voip.

#4 usasma

usasma

    Still visually handicapped, new avatar (a camel) :0)


  • Members
  • 16,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:03:06 AM

Posted 12 March 2008 - 08:10 PM

Do you use the Hibernate or Sleep options? That can cause duplicate IP addresses. When this happens, your system hibernates/sleeps and saves the IP address that's in use. But the network sees it as not being used (since the computer isn't communicating), so it reissues it. Then, when you resume from hibernate/sleep you'll still have the old IP address which has since been assigned to someone else.
- John
**If you need a more detailed explanation, please ask for it. I have the Knack. **

#5 Verywierd

Verywierd
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:06 AM

Posted 13 March 2008 - 01:10 AM

Do you use the Hibernate or Sleep options? That can cause duplicate IP addresses. When this happens, your system hibernates/sleeps and saves the IP address that's in use. But the network sees it as not being used (since the computer isn't communicating), so it reissues it. Then, when you resume from hibernate/sleep you'll still have the old IP address which has since been assigned to someone else.


Nope. The machine is always on unless I deliberately turn it off. Not even screensaver. I can go along for half a day with no problem, then the popups start for a while, sometimes just half and hour, other times many hours. Then it can go away again. And all the time my net connection is uniterrupted. Downloads continue as normal, I can watch streaming video on YouTube but I just get the (multiple) popup(s) blocking the screen and have to manually close it.

I have been working on this for months now and have tried all the network error fixes, removed firewalls, removed antivirus, switched to using openDNS. I went abroad with this same laptop and had no popups when I used another connection in the hotel or in someone's home. I have given up trying to troubleshoot as nothing seems to actually be affected. All I want is to be able to turn off the warnings.

Edited by Verywierd, 13 March 2008 - 01:11 AM.


#6 usasma

usasma

    Still visually handicapped, new avatar (a camel) :0)


  • Members
  • 16,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:03:06 AM

Posted 13 March 2008 - 08:43 AM

I'd suspect it was one of the other users on the network that's using Hibernation/Sleep then - and you're being assigned the IP address that they'd stored when they went to sleep. Contact your ISP to see what they can do to prevent this (issuing you a static IP would be the best bet, but that'd restrict their ability to utilize the number of IP addresses that they've got).

I have no clue about how to turn off the warnings - nor do I think that it's wise to do so. Rather, I'd right click on the connection and select "Repair". That'll stop the popups until the next time you conflict with the "sleeper".
- John
**If you need a more detailed explanation, please ask for it. I have the Knack. **

#7 Verywierd

Verywierd
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:06 AM

Posted 13 March 2008 - 10:05 AM

I'd suspect it was one of the other users on the network that's using Hibernation/Sleep then - and you're being assigned the IP address that they'd stored when they went to sleep. Contact your ISP to see what they can do to prevent this (issuing you a static IP would be the best bet, but that'd restrict their ability to utilize the number of IP addresses that they've got).

I have no clue about how to turn off the warnings - nor do I think that it's wise to do so. Rather, I'd right click on the connection and select "Repair". That'll stop the popups until the next time you conflict with the "sleeper".


Thanks for the advice and you are quite possibly right about the sleep mode problem.

I am dealing with an ISP whose technicians do not speak English, or not enough of it the deal with difficult system problems like this. They simply are not capable of responding.

Repair does not work. I have tried it. I have also tried IPConfig /release /renew commands (I even have a batch file to do it). No effect.

So, anyone know how to disable the warning? :thumbsup:

#8 usasma

usasma

    Still visually handicapped, new avatar (a camel) :0)


  • Members
  • 16,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:03:06 AM

Posted 13 March 2008 - 06:38 PM

If a repair or ipconfig /release and /renew don't work - then it's not the problem that I've described.

That being the case, it'd have to be (IMO) either the drivers for your network card, or the Windows internet settings that aren't working properly. To repair TCP/IP and or the Winsock stack in XP:
http://support.microsoft.com/kb/299357
http://support.microsoft.com/kb/811259

The only other solution that I've seen mentioned is to run ipconfig /all to see if there's any duplication of IP addresses there. The supposition being that 2 devices may have the same IP address. If so, then you can disable one of them and that will stop the error message.
- John
**If you need a more detailed explanation, please ask for it. I have the Knack. **

#9 Verywierd

Verywierd
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:06 AM

Posted 14 March 2008 - 12:19 AM

If a repair or ipconfig /release and /renew don't work - then it's not the problem that I've described.

That being the case, it'd have to be (IMO) either the drivers for your network card, or the Windows internet settings that aren't working properly. To repair TCP/IP and or the Winsock stack in XP:
http://support.microsoft.com/kb/299357
http://support.microsoft.com/kb/811259

The only other solution that I've seen mentioned is to run ipconfig /all to see if there's any duplication of IP addresses there. The supposition being that 2 devices may have the same IP address. If so, then you can disable one of them and that will stop the error message.


No, I've done all of those too. ipconfig /all shows no duplication. I've been working on this for a more than a quarter of a year and have exhausted all likely fixes, hence the request for a way to disable the popup. Thanks anyway :thumbsup:

#10 usasma

usasma

    Still visually handicapped, new avatar (a camel) :0)


  • Members
  • 16,690 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:03:06 AM

Posted 14 March 2008 - 04:09 PM

The only other thing that I can think of is disabling "balloon tips" or disabling the notification for limited connectivity. But I don't know if that'll affect the popup for the IP address conflict.

Good luck!
- John
**If you need a more detailed explanation, please ask for it. I have the Knack. **

#11 notcpusmart

notcpusmart

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:06 AM

Posted 10 January 2009 - 12:31 AM

I have this same problem, although I am using wireless. I did release and renew my IP address in my router settings. This all started right after I had some malware issues which I went to safe mode and then also used Malwarebytes Anti-Malware to remove Malware and who knows what else.

Any suggestions on getting this message about duplicate IP address corrected? And yes, it does cause a slight interruption in internet connection.

I did try this as previously mentioned. http://support.microsoft.com/kb/299357 but still does the same thing.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users